ｐAchi作業時間記録

作業時間記録

ご意見、ご質問、感想は掲示板へ書き込んでください。

シェアウェア代金（１,８９０円）の支払い方法はこちら

Version1.1.0用

作業時間を簡単に記録して集計できるようにしました。近頃は時間を管理せずに予定と進捗状況だけで管理しているのですが、自分自身でどれだけの時間を費やしているのかを記録しておきたいと思い作成しました。ですので、本当の時間管理になっていない部分もあるかと思います。また、簡単なメモや小遣い、交通費などもいっぺんに面倒をみておこうということで小さな機能を付加してあります。簡単に！便利に！だけを目的にしましたので本格的な機能とはなっていません。

ほとんどの作業はタップ、タップ＆ホールドで指示します。データは数値であれば画面の１０キーか電卓を使用できます。文字はいくつかはコンボボックスを用意し、過去データを参照できるようにしていますが、基本的には入力する以外にはありません。

インストール直後の初期設定操作が必要です。データ入力後では変更できない項目もありますので、必ず初期設定を行ってください。

制限事項

  • プロジェクト別時間管理を使用しない場合、1日に入力可能なプロジェクトは8件までです。

  • プロジェクト別時間管理を使用しない場合、1日に入力可能な時刻バーの塊は１３件までです。

  • プロジェクトは最大２８件まで登録できます。

  • メモリを約３MB使用します。また、なるべく高速で動作させてください。

以下の説明では開発中画面を使用していますので、実際の画面と若干異なる場合があります。

目次

セットアップ手順概要
＝ [image] ライセンスキー入力
＝ [image] 初期設定
＝ [image] 基本設定
＝＝ [image] 基本締日
＝＝ [image] 作業時間、休憩時間
＝＝ [image] 休日、祝日
＝＝ [image] 壁紙
＝＝ [image] メールアドレス
＝＝ [image] 受信トレイ以外のメールプログラム
＝＝ [image] 外貨通貨
＝＝ [image] バイオリズム
＝ [image] 表示設定
プロジェクト定義
作業時間の入力
＝ [image] 作業の開始終了時間
＝ [image] プロジェクト作業時間指定
＝ [image] 月間作業時間出力
プロジェクトの管理
＝ [image] プロジェクト予定
＝ [image] プロジェクト順序
＝ [image] プロジェクト再利用
＝ [image] プロジェクト別作業時間出力
作業時間以外のデータ
＝ [image] 交通費
＝ [image] メモ
＝ [image] リンク
＝ [image] 小遣い
＝ [image] グラフ
日付移動
時刻移動
ファイル操作
バックアップとリストア
データファイルと状態表示
新規メニュー
バージョンアップ情報
＝ [image] バイオリズム

セットアップ手順概要

ライセンスキー入力

立ち上げると、以下の画面が出ます。この画面はシェアウェア登録していただくと表示されなくなります。シェアウェア代金を支払うとライセンスキーが発行されますので、そのライセンスキーを指定する画面です。試用する場合は「閉じる」を押してください。その後、「はい」を答えてください。試用中でも機能制限はありません。

     試用中は画面上に文字が表示されます。

下の画面はライセンスキーを入れた状態です。説明の邪魔なのでライセンスキーを入れた状態（試用解除状態）で説明します。

  Ｖｅｒｓｉｏｎ１の場合

Ｖｅｒｓｉｏｎ２の場合

バージョン２の場合は画面をタップすることで、初期設定ダイアログが次々と出ます。

＝＞

＝＞ [image] ＝＞

＝＞ [image] ＝＞

＝＞ [image] ＝＞

＝＞ [image] ＝＞

＝＞ [image] ＝＞

＝＞ [image] ＝＞

＝＞ [image] ＝＞

＝＞ [image] ＝＞

＝＞

初期設定

最初に、メニュー「設定」－「初期設定」を選択してください。

１日を何時から始めるかを指定します。これはデータ入力後に変更できません。（変更できますが、入力済みデータの整合性は失われます）

会社の深夜、早朝勤務時間体系が決まっている場合はその１日の作業時間の区切りとなる時刻を指定します。深夜や早朝作業の無い方に推奨する時刻は起床する時刻の１時間前くらいです。ここで指定した時刻で画面右側の時刻バーの先頭が決まります。

プロジェクト開始終了時刻を記録するをチェックすることで、プロジェクト別の開始終了時刻を管理できるようになります。（Ｖｅｒｓｉｏｎ２以降）

基本設定

基本締日

基本締日：会社の作業時間集計の締日を指定します。２０日締めなら２０です。

注意する：締日以前のデータ入力に対して締日をすぎているということを知らせるかどうかです。

小遣繰越： 小遣い残高を管理しています。「小遣い締」の日付の残高です。

小遣い締：この日で小遣いデータを締めたということです。ファイル出力してOKすると繰越残高と共に更新されます。

交通費締：この日で交通費データを締めたということです。ファイル出力してOKすると更新されます。

メモ締：この日でメモデータを締めたということです。ファイル出力してOKすると更新されます。

リンク締：この日でリンクデータを締めたということです。ファイル出力してOKすると更新されます。

１～５：グラフデータの締め日です。

上記締日と繰越残高は必要があれば更新しても構いません。データの管理日が変更されるので、ファイル出力時に２重出力や出力不足が起きる場合がありますが、各データはそのまま保持されますので、締め日の理解できる方はこれらを変更しても問題ありません。

データによっては締め日を持たないものもあります。

作業時間

作業時間と休憩時間の設定を行います。上記の様に作業開始時刻、定時の終了時刻、定時の作業時間を指定してください。

次に休憩時間が決まっている場合は指定してください。決まっていない場合でも、昼休みなどは適当に入れてください。

  この様に定時の線と休憩時間が表示されます。（休日の場合は表示されません）

休日、祝日

休日となる曜日を選択してください。

初期ボタンを押すと日本の祝日が自動設定されます。春分の日と秋分の日は閏年にずれる場合がありますので、政府の発表を参照するか、カレンダーを参照してください。リストの「追加」を選択した後、日本の祝日用にコンボボックスに説明がありますので、それを選択し内容を参考にして、年、月、日を指定して「追加」ボタンを押してください。間違ったら、リスト上の項目を選択すれば、値の変更が可能となりますので、変更後、「更新」ボタンを押してください。２重に登録してしまった場合は「削除」ボタンを押してください。 振替有効の場合は振替有効を選択してください。休日が稼働日となる場合は、「稼働日」を選択して登録してください。「稼働日」登録されている日は曜日が休日指定であっても「稼働日：営業日」として扱います。

なお、祝日内容はレジストリに記憶します。データファイルには記憶されません。

壁紙

メニューを選択して、壁紙を指定してください。「参照」ボタンで、「My Documents」配下のJPEG一覧を表示させて、壁紙を選択してください。壁紙は元イメージそのものではなく、左のスクロールバーで濃さを指定できます。下のスクロールバーで色合いを指定できます。色合いはスクロールバーの横に表示されます。

タイル指定とは、小さな画像をタイルを敷き詰めたように表示することです。

画面の文字色、枠の色などは下記の方法で変更できます。

色設定

画面で描画している文字や枠の色を変更できます。

色設定画面の左のメニューボタンを押したところです。色の設定内容をファイルに保存できます。

色設定は、右上のリストボックスで変更したい項目を指定して、カラーバーをタップするとタップしたところの色が取り込まれます。サンプル表示の下の１００は透過度を指定できます。項目によってはこの透過度は無効です。任意の壁紙を設定した後、色指定で各文字や枠の色を変更すれば、暗い画面や白い画面でも視認性がよくなります。

メールアドレス

一部の機能にメールにファイルを添付して送信できるボタンがあります。その時に使用するメールアドレスと受信トレイのフォルダ名です。受信トレイが準備されていれば、.DEFAULTの場所にはActiveSyncが表示されるようになります。別のアカウントを設定すれば、それも表示されますので、任意のアカウントを選択しておいてください。但し、実際の送信は、受信トレイで該当のアカウント送信を行わなければ送信できません。

メーラーを指定

受信トレイ以外のメールプログラムを使う場合に指定します。 上記はnPOPの例です。それぞれのメーラーでの起動コマンドを設定してください。起動コマンドで指定できないメーラーの場合は、プログラムの指定だけを行っておいてください。メール送信する際にプログラムが起動されます。

通貨単位

小遣いを外貨で入力することができます。その場合の初期値となる為替レートと通貨記号、セントを使うかどうかなどを指定します。

画面を開くと３つの外貨が表示されます。Okボタンを押すと記憶されます。なお、￥（日本円）を削除しないでください。また、為替レートの有効桁数は５桁程度ですので大きな外貨金額を指定すると桁落ちが発生する場合があります。

表示設定

時刻バーの表示開始位置と単位、時間の表示形式、時差表示を指定します。

時間単位：この時間単位で作業時間を指定します。１５分なら０、１５、３０、４５となります。

作業開始：プログラムを立ち上げた時に最初に表示される時刻バーの開始時間です。

表示形式： HH:MM形式か、HH.hh形式かを指定します。 ３時間３０分の場合　時分で表示すれば３：３０　時間＋少数なら ３．５または３．５０となります。

時差表示：ここで指定した時間差を時刻バーに表示します。時刻バーの表示だけが変更され、その他の時刻は変更されません。現地時間（本来の時差）処理は行っていません。

プロジェクト定義

画面左上の「日常業務、他」の列の下の空白の場所をタップ＆ホールドするとメニューが出ます。「プロジェクト定義」を選択するとプロジェクト内容を定義（変更）できます。

プロジェクトコード：ファイル出力時に使用されます。会社の会計コードを入れるものですので不要であれば何も指定しなくても構いません。

フォルダ連動：これをチェックしておくと、My Documentsの下にプロジェクト名のフォルダが作られます。

プロジェクト：プロジェクト名を指定します。空白にするとプロジェクトが無効になります。

予定時間：このプロジェクトの予定時間を２００時間なら２００と指定します。プロジェクト表示の集計欄の上に緑色の線で表されます。

締め日：プロジェクトの締め日です。プロジェクト毎にファイル出力したり、集計したりする場合の締め日です。月間作業時間とは関係ありません。

  このように、「日常業務、他」の下に新しいﾌﾟﾛｼﾞｪｸﾄが追加されました。

ﾌﾟﾛｼﾞｪｸﾄは全部で２８個指定できます。長い間使用していると、新しいﾌﾟﾛｼﾞｪｸﾄを追加できなくなります。その場合は終了したﾌﾟﾛｼﾞｪｸﾄに再利用処理を指定してﾃﾞｰﾀを書き換えてから新しいﾌﾟﾛｼﾞｪｸﾄにしてください。（プロジェクト順序を参照）

作業時間の入力

作業開始から終了の入力

  • プロジェクト別開始終了時間を管理する場合の指定方法

  • プロジェクト別開始終了時間を管理しない場合の指定方法

プロジェクト別開始終了時間を管理する場合の指定方法

  プロジェクト別に記録したい時刻をドラッグします。

プロジェクトを選択します。開始と終了時刻も訂正できます。作業内容もメモ入力できます。作業内容をカンマ(,)で区切れば、区切った内容を３個まで記憶して下段のコンボボックスに次回から表示しますので、再入力の場合に便利です。休憩時間を無視するか、有効にするかの指定はチェックボックスで行います。時刻バーの表示パターンは休憩時間を無効にしても変化しません。

当日に記録のあるプロジェクトには上記のように時間数と時刻バーの色パターンが表示されます。これを繰り返すことで１日分の作業時間を記録します。

プロジェクト別開始終了時間を管理しない場合の指定方法

時刻バーをドラッグすることで開始終了を入力します。左側はドラッグ中の画面で、スタイラスの位置は時刻バーの上（例では１５：３０）に表示されます。

スタイラスを離すと右側のように休憩時間でない時間帯の色が変わります。このとき、プロジェクト表の中央下の１日の時間数が赤く表示されます。この赤く表示された時間数が開始から終了までの有効作業時間ということです。赤く表示されている理由は１日の有効時間とプロジェクト毎の合計時間が合致していないという意味です。次のプロジェクト時間を入力することで青に戻ります。

追加したい場合はその時刻バーの場所をドラッグしてください。削除したい場合もその場所をドラッグしてください。現在有効時間と重なる場合にはスタイラスを離したときにメニューが表示されますので、「追加」「削除」を選択してください。最初はちょっと戸惑うかもしれませんが、慣れれば簡単に入力できるようになります。

プロジェクト時間の入力

この日のプロジェクトの作業時間を入力するには、１日の作業時間の場所をドラッグします。左の画面の白地に黒文字で表示されている場所からドラッグを始めて右側にドラッグすると時間が増えます。左側にドラッグすると時間が減ります。スタイラスを離した時点の時間数を覚えます。最低で０、最大でも１日の有効時間数を超えることはありません。　上記例では２：１５を指定しましたが、１日の有効作業時間は５：３０のため、５：３０はまだ赤く表示されています。

同様に、日常業務に残りを割り当てることにします。　日常業務の１日の時間数の位置から右側にドラッグをします。

日常業務に３：１５が割り当てられ、全体で５：３０となったので、有効時間数５：３０が青に戻りました。

この赤、青の状態はカレンダーの日付色と同期していますので、１日の合計が合致しているかどうかをカレンダーからも見ることができます。

ﾌﾟﾛｼﾞｪｸﾄ別の作業時間の入力方法は、上記以外にも応用できます。

まず、該当のﾌﾟﾛｼﾞｪｸﾄを作業した時間だけを右側の時刻バーに設定します。次に、該当ﾌﾟﾛｼﾞｪｸﾄに作業時間を加算します。その後、別のﾌﾟﾛｼﾞｪｸﾄの作業した時間だけを右側の時刻バーに追加します。そして、該当ﾌﾟﾛｼﾞｪｸﾄに作業時間を加算します。これを繰り返すことで1日分の作業時間となります。できれば午前中の作業が終わった時点で1回、次の休憩で1回、帰宅前に1回と入力することで簡単に入力できると思います。それぞれのﾌﾟﾛｼﾞｪｸﾄ作業が終わった時点で毎回入力するという方法もあります。

月間作業時間出力

開始日と終了日（締日）を選択して、ファイルの出力形式を選択してください。

OKボタンを押すと出力を開始します。

起動ボタンで内容を確認できます。　キャンセルボタンで出力ファイルを削除します。

ポケットエクセル
カラム幅や表示形式を
変更すれば＝＞

時間は時間表示形式に基づいて出力されます。時：分の形式の場合は日付/時刻データとしてエクセルに出力されます。集計方法などはエクセルの説明書を参照してください。また、ここで出力している合計値はエクセルの式ではありません。文字列として出力しています。エクセルで値を書き直す場合は式を指定して再計算させてください。　時.小数桁で表示される場合は数値として出力されます。この場合は単純な数値の計算となります。

０：００の消し方はセルの書式に ユーザ定義書式を使って、HH:MM；；としてください。

プロジェクトの管理

プロジェクトの入力以外に、プロジェクトの表示順序の変更、プロジェクトの再利用、プロジェクト別の時間集計などができます。

プロジェクト予定

プロジェクト別開始終了時間を管理する指定を行っている場合はプロジェクトの予定を入力できます。

タップ＆ホールドします。

予定を選択します。

新規ボタンを押して新しい工程を入れます。

段階点：マイルストーン（里標）の場合にチェックします。マイルストーンは工程間の整合ポイントで、顧客提出する日、完了ミーティングする日など他の人との予定を同期させなければならない日を指定します。

段階点の場合

開始予定日：予定日を指定します。
完了：完了した場合、チェックを入れて完了日を指定します。

段階点で無い、通常工程の場合

開始予定日：この工程が開始可能となる段階点を選択できます。日付は開始予定日です。
完了予定日：終了予定日を指定します。また、この工程の終了を待たなければならない段階点を指定できます。
予定時間：完了予定日から開始予定日（ともに指定日を含みます）の営業日を加算した時間数が表示されています。この時間数で良ければボタンを押します。違うのであれば時間数を指定します。自分の作業時間とプロジェクト進捗が関連を持たないのであれば０時間のままでかまいません。
進捗手入力：チェックをはずすと作業時間を自分の作業時間の加算にて求めます。チェックを入れた場合は進捗状況を指定します（０％～１００％）
完了：完了した場合、チェックを入れます。進捗手入力でない場合、完了日は開始日を指定しておくと進捗計算時に最終作業日で更新されます。手入力の場合は完了日付を指定してください。

上のチェックを外すとこのように下半分に一覧表が出ます。

設定例です。

このように予定を設定しておけば、主画面でプロジェクト名をタップすると、予定内容を表示します。

プロジェクト順序

日常業務以外のﾌﾟﾛｼﾞｪｸﾄは表示順序を変更することが出来ます。ﾌﾟﾛｼﾞｪｸﾄ一覧はスクロールします。スクロールは緑色の矢印 [image] をタップします。日常業務はスクロールしません。

ﾌﾟﾛｼﾞｪｸﾄの表示順序を変更するには、ﾌﾟﾛｼﾞｪｸﾄ名（上記画面の赤い線の中）をタップ＆ホールドしてメニューを出します。

リスト上のﾌﾟﾛｼﾞｪｸﾄを選択し、「下へ」、「上へ」にてﾌﾟﾛｼﾞｪｸﾄの表示位置を調整できます。「編集」を押すと定義画面が表示されて内容を変更することができます。

「再利用」については次項を参照してください。

プロジェクト再利用

ﾌﾟﾛｼﾞｪｸﾄは最大で１番から２８番まで２８件利用できます。番号０は日常業務、２９は再利用調整用としてシステム予約されています。日常業務はﾌﾟﾛｼﾞｪｸﾄ分類できない作業を纏めたもので、「その他」を意味します。

ﾌﾟﾛｼﾞｪｸﾄには数に限りがありますので、長期間使用していると、ﾌﾟﾛｼﾞｪｸﾄの順序を変えるだけでは新しいﾌﾟﾛｼﾞｪｸﾄを入力できなくなる場合があります。このような場合、現在のﾌﾟﾛｼﾞｪｸﾄを削除して、新しいﾌﾟﾛｼﾞｪｸﾄを入力できれば良いのですが、システム内にﾌﾟﾛｼﾞｪｸﾄコードに対応した状態で覚えこんでいる内容があります。それらを共に削除するというのは強引で、メモやその他のデータも参照できなくなるのは不便です。

削除の代わりに、再利用可能な準備をするのがこのﾌﾟﾛｼﾞｪｸﾄ再利用です。

再利用するには、現在の作業時間とﾌﾟﾛｼﾞｪｸﾄコードを再利用調整用に集約します。つまり、どのようなﾌﾟﾛｼﾞｪｸﾄでも２９番の再利用調整ﾌﾟﾛｼﾞｪｸﾄに合算してしまうということです。そうすることにより、現在のﾌﾟﾛｼﾞｪｸﾄコードは意味をなさなくなり、新しいﾌﾟﾛｼﾞｪｸﾄとして再利用できます。

手順は以下の通りです。

ﾌﾟﾛｼﾞｪｸﾄ順序を指定する画面を出します。

再利用したいﾌﾟﾛｼﾞｪｸﾄを選択し、「再利用」ボタンを押します。

「はい」をタップ

「はい」をタップ

Okを押します。

空のﾌﾟﾛｼﾞｪｸﾄ定義が表示されますので、新しいﾌﾟﾛｼﾞｪｸﾄを定義してください。

プロジェクト別作業時間出力

ﾌﾟﾛｼﾞｪｸﾄ別の作業時間を出力します。月間作業時間出力との違いは、ここで指定したﾌﾟﾛｼﾞｪｸﾄのみを対象として、ﾌﾟﾛｼﾞｪｸﾄの締日で出力されることが異なります。

出力形式などは月間作業時間出力と同じです。

出力したいﾌﾟﾛｼﾞｪｸﾄ名をタップ＆ホールドしてメニューを出してください。

期間と出力形式を選択し、OKボタンを押します。

「起動」ボタンで内容を確認できます。キャンセルボタンを押すと出力したファイルを削除します。

この作業は何度でも可能です。ファイル名は YYYYMM_ﾌﾟﾛｼﾞｪｸﾄ名となっています。

前回出力の締日は記憶しません。出力しようとした日付から期間を求めて表示しています。

作業時間以外のデータ入力

作業時間以外に以下の項目を入力し、管理することができます。 データをエクセル形式やCSV形式でファイル出力すれば、ActiveSyncで母艦PCにCOPYした後、PCのエクセルで清算書などを作成できます。

  • 交通費の説明

  • メモの説明

  • ファイルリンクの説明

  • 小遣いの説明

  • グラフ用データの説明

以下に簡単に入力概要を説明します。詳細はそれぞれの説明を参照してください。

交通費の入力例で説明します。

  時刻バーの下に５つのアイコン [image] が並んでいます。これらをドラッグして時刻バーの横に持って行くことで新規データの入力ができます。時刻バーに対応させることで時刻を指定できます。 現在時刻（選択している日付に関係なく、機械の日付＆時刻）での新規入力はアイコンをタップ＆ホールドしてメニューの「新規」を選択してください。交通費は [image] です。

必要な項目を選択＆入力してください。金額は画面のテンキーから入力できます。「電卓」ボタンでPocketPCの電卓を起動できます。「電卓」を終了すると結果は自動的に取り込まれています。以下のようになります。

同様に各アイコンをドラッグしたり、タップ＆ホールドで「新規」を選択すると下記の画面がでます。

グラフ用データはグラフデータ設定を行わないと意味を持ちません。

入力データは以下のような形で時刻バーの横に表示されるようになります。 データを修正するにはこのアイコンをタップしてください。（一覧からでも修正できます）

交通費

交通費を記憶できます。清算のためのファイル出力もできます。

入力

入力する方法はいくつかあります。

●画面右下 [image] のアイコン [image] をドラッグして時刻バーの横にもっていく

●画面右下 [image] のアイコン [image] をタップ する。

●画面右下 [image] のアイコン [image] をタップ＆ホールドして、「新規」メニューを選択する

●画面右下 [image] のアイコン [image] をタップ＆ホールドして、「一覧」「検索」を選択後、その画面のメニューで「新規」を選択する

●メニューの「新規」で、「メモ」を選択する。

●メニューバー内の新規アイコン [image] をクリックして「メモ」を選択する

すべての新規データはシステム時刻で作られます。

新規画面は以下のようになります。

ﾌﾟﾛｼﾞｪｸﾄを選択してください。該当ﾌﾟﾛｼﾞｪｸﾄが無い場合は日常業務です。

内容を選択してください。（例：訪問）

交通手段を選択してください。（例：電車）

続けて訪問先を入力してください。（例：上郷工務店）

金額を指定します。SIPを閉じてテンキーで指定できます。SIPでは入力できません。または「電卓」ボタンを押して電卓で入力します。（参照：電卓の動作）

なお、Ver1.1以降では金額欄がコンボボックスになっていますので、過去に入力した金額を選択することも可能です。

OKで確定します。

一覧、検索

のアイコン [image] をタップ＆ホールドして、「一覧」「検索」を選択します。

検索を選択した場合は検索キーと検索ボタンが表示されます。検索キーを指定し、「検索」ボタンを押すと、キーと同じ内容を持つデータを残して表示します。順に絞り込むことができます。

日付は任意の範囲を指定できます。

Goボタンはリストでデータを１つ選択した後に押すことで、この画面を閉じてその日に移動します。

メニューボタン [image] を押すとメニューが出ます。

新規...：新規（システム時刻）データの入力を行います。

編集...：リストでデータを選択すると有効になります。データを変更できます。

ファイル出力：表示または選択しているデータをタブ区切りﾃｷｽﾄ形式でファイルに出力します。

ﾌﾟﾛｼﾞｪｸﾄ別出力：表示または選択しているデータをﾌﾟﾛｼﾞｪｸﾄ別にタブ区切りﾃｷｽﾄ形式でファイルに出力します。

複数選択：リストで任意の複数のデータを選択することができます。選択後、ファイル出力では選択データだけが出力されます。

一覧を終了：この画面を閉じます。OKボタンでも同じです。

ファイル出力

期間とファイル形式を指定してOKボタンを押します。

OKボタンで締日を覚えて確定します。キャンセルボタンで出力ファイルを削除します。

メモ

短いメモを記憶できます。ﾃｷｽﾄ形式以外のマルチメディアデータや大きなメモは別のツール（PocketPCのメモなど）で作成した後、ファイルリンクで管理してください。

入力

入力する方法はいくつかあります。

●画面右下 [image] のアイコン [image] をドラッグして時刻バーの横にもっていく

●画面右下 [image] のアイコン [image] をタップする

●画面右下 [image] のアイコン [image] をタップ＆ホールドして、「新規」メニューを選択する

●画面右下 [image] のアイコン [image] をタップ＆ホールドして、「一覧」「検索」を選択後、その画面のメニューで「新規」を選択する

●メニューの「新規」で、「メモ」を選択する。

●メニューバー内の新規アイコン [image] をクリックして「メモ」を選択する

すべての新規データはシステム時刻で作られます。

新規画面は以下のようになります。

ﾌﾟﾛｼﾞｪｸﾄを選択してください。（参照：ﾌﾟﾛｼﾞｪｸﾄの管理）

右横にはメモの状態を選択できます。（検討、作業、済み、保存、削除）これらの状態は一覧表示などを行う場合に表示選択できます。

メモ内容を入力します。（タップ＆ホールドで貼付やコピーができます）

「予定表に通知設定」を押すとPocketOutlookの予定表にメモ内容のタイトルで予定として書込みます。アラーム通知として使用できます。このボタンを押した数だけ設定してしまいますので注意してください。また設定済みかどうかは管理していません。表示されている日付、時刻で設定されます。

OKボタンを押して記憶させます。

一覧、検索

のアイコン [image] をタップ＆ホールドして、「一覧」「検索」を選択します。

検索を選択した場合は検索キーと検索ボタンが表示されます。検索キーを指定し、「検索」ボタンを押すと、キーと同じ内容を持つデータを残して表示します。順に絞り込むことができます。

日付は任意の範囲を指定できます。

Goボタンはリストでデータを１つ選択した後に押すことで、この画面を閉じてその日に移動します。

メニューボタン [image] を押すとメニューが出ます。

新規...：新規（システム時刻）データの入力を行います。

編集...：リストでデータを選択すると有効になります。データを変更できます。

ファイル出力：表示または選択しているデータをタブ区切りﾃｷｽﾄ形式でファイルに出力します。

ﾌﾟﾛｼﾞｪｸﾄ別出力：表示または選択しているデータをﾌﾟﾛｼﾞｪｸﾄ別にタブ区切りﾃｷｽﾄ形式でファイルに出力します。

複数選択：リストで任意の複数のデータを選択することができます。選択後、ファイル出力では選択データだけが出力されます。

検討、作業、済み、保存、削除：表示するメモの状態を指定できます。チェックが付いているものが表示されます。

一覧を終了：この画面を閉じます。OKボタンでも同じです。

メモ項目をタップ＆ホールドするとメニューが出ます。

＝＝＞検討、作業、済み、保存、削除：メモの状態をそれぞれの状態に書き換えます。前述のメニューの編集でデータを開いてから状態を書き換えることもできますが、ここでは選択＆状態書換という作業ができます。

メモの削除状態

メモ状態の削除状態は通常の削除ではなく、復元できます。通常の削除では復元できませんが、メモはメモの状態として削除状態を持つことができます。簡単に言えば一時的な削除状態にすることができるということです。削除データを表示させて、いつでも元の状態に戻すことができます。

あまりの多くの削除状態のメモが増えると効率が下がりますので、一時的な削除状態のメモをレコード削除とすることが出来ます。

ここで削除されたメモは復元できなくなります。

ファイル出力

メモをポケットエクセル形式、CSV形式、タブ区切りﾃｷｽﾄ形式でファイルに出力できます。

対象期間と形式を指定してOKボタンを押してください。

[起動」で内容を確認できます。CSVとTXTで関連づけが無い場合は本プログラムが内容を表示します。

ポケットエクセル形式 CSV形式 タブ区切りTXT形式

Pocket Excel

本プログラム

Pocket Word

この画面でOKを押すと今回の締日を覚えます。キャンセルを押すと出力したファイルが残っていれば（移動や削除、名前変更をしていなければ）削除します。

ファイルリンク

PocketPC内のファイルへのリンクを保持できます。

入力

入力する方法はいくつかあります。

●画面右下 [image] のアイコン [image] をドラッグして時刻バーの横にもっていく

●画面右下 [image] のアイコン [image] をタップする

●画面右下 [image] のアイコン [image] をタップ＆ホールドして、「新規」メニューを選択する

●画面右下 [image] のアイコン [image] をタップ＆ホールドして、「一覧」「検索」を選択後、その画面のメニューで「新規」を選択する

●メニューの「新規」で、「リンク」を選択する。

●メニューバー内の新規アイコン [image] をクリックして「リンク」を選択する

すべての新規データはシステム時刻で作られます。

新規画面は以下のようになります。

にてﾌﾟﾛｼﾞｪｸﾄを選択します。（参照：ﾌﾟﾛｼﾞｪｸﾄの管理）

参照ボタンでリンクを保持するファイルを選択できます。

未リンクのデータのみ表示されるようになっています。

例として画像ファイルをリンクします。

画像ファイル（JPG、BMPのみ）は画面に表示されます。TXT、CSVファイルは先頭文字が表示されます。それ以外は作成日付はサイズが表示されます。

「開」ボタンを押すと関連づけされているプログラムでファイルを開きます。

「録」ボタンを押すと、録音するファイル名を指定し、マイクから録音することができます。

録音した後、OKボタンを押すと、リンクファイル名が更新されます。（上記の画像と録音は関係ありません。キャンセルを押すと元に戻るためです）

WAVファイルは「開」ボタンで再生します。

Okボタンで確定します。

基本的にどのようなファイルでもリンクできます。「開」で実行（表示、再生など）するためにはプログラムと関連づけがされていなければなりません。

なお、URLも保持できます。インターネットブラウザで保持したいWebサイトを表示させた後、URLをCOPYしてください。この画面で「貼」ボタンを押します。URLはURLの文字列を保持しているのであり、Web画面を保持しているわけではありませんので、インターネットに接続できない環境で、「開」ボタンを押した場合、正常に表示されるかどうかは保証できません。（ブラウザの内部バッファに残っている場合は表示されることもあります）

時刻バーの横に登録されたリンクがアイコン表示されます。このアイコンをタップすると、リンクされたファイルが実行されます。編集したい場合はタップ＆ホールドすれば編集画面が出ます。

一覧、検索

のアイコン [image] をタップ＆ホールドして、「一覧」「検索」を選択します。

検索を選択した場合は検索キーと検索ボタンが表示されます。検索キーを指定し、「検索」ボタンを押すと、キーと同じ内容を持つデータを残して表示します。順に絞り込むことができます。

日付は任意の範囲を指定できます。

Goボタンはリストでデータを１つ選択した後に押すことで、この画面を閉じてその日に移動します。

メニューボタン [image] を押すとメニューが出ます。

新規...：新規（システム時刻）データの入力を行います。

編集...：リストでデータを選択すると有効になります。データを変更できます。

ファイル出力：表示または選択しているデータをタブ区切りﾃｷｽﾄ形式でファイルに出力します。

ﾌﾟﾛｼﾞｪｸﾄ別出力：表示または選択しているデータをﾌﾟﾛｼﾞｪｸﾄ別にタブ区切りﾃｷｽﾄ形式でファイルに出力します。

複数選択：リストで任意の複数のデータを選択することができます。選択後、ファイル出力では選択データだけが出力されます。

一覧を終了：この画面を閉じます。OKボタンでも同じです。

ファイル出力

現バージョンではサポートしていません。

小遣い

小遣いデータは単純な支出記録です。残高管理を行う場合の簡単な方法は入金処理（金額にマイナス値を入れる）してください。

入力

入力する方法はいくつかあります。

●画面右下のアイコン [image] をドラッグして時刻バーの横にもっていく

●画面右下のアイコン [image] をタップ＆ホールドして、「新規」メニューを選択する

●画面右下のアイコン [image] をタップ＆ホールドして、「一覧」「検索」を選択後、その画面のメニューで「新規」を選択する

●メニューの「新規」で、「小遣い」を選択する。

●メニューバー内の新規アイコンをクリックして「小遣い」を選択する

すべての新規データはシステム時刻で作られます。

新規画面は以下のようになります。

ﾌﾟﾛｼﾞｪｸﾄを選択してください。新規では「日常業務、他」になっています。（参照：ﾌﾟﾛｼﾞｪｸﾄの管理）

左のコンボは費目です。リストから選択するか、新しい費目を指定してください。

右のコンボは内容です。最初は何もありませんが、入力データを順に覚えていきます。

金額は上記のテンキーで入力します。電卓を使用する場合は「電卓」ボタンを押してください。（参照：電卓ボタンの動き）

BSキーはバックスペースキーで、最下位桁（右端）を消します。

個人のチェックボックスは個人データということを覚えます。（会社の清算データと区別したい場合などに使います）

外貨の入力方法

外貨を入力するには、外貨記号などを設定しておく必要があります。（参照：通貨単位）

外貨記号を選択します。レートが表示され、その下に日本円換算値が表示されます。レートの有効桁数は5桁程度ですので、あまりにおおきな金額を指定すると計算誤差が出る場合があります。日本円換算値は記憶されませんので注意してください。

入力完了したデータを変更する場合は時刻バーの横のアイコン（ [image] に金額表示）をタップしてください。入力画面が出ます。

一覧、検索

の [image] アイコンをタップ＆ホールドしてメニューを出して「一覧」または「検索」を選択します。

検索画面の例です。一覧ではこの画面の検索キーと検索ボタンが表示されません。

検索は検索キーを指定し、「検索」ボタンを押すと、キーと同じ内容を持つデータを残して表示します。順に絞り込むことができます。

日付は任意の範囲を指定できます。

Goボタンはリストでデータを１つ選択した後に押すことで、この画面を閉じてその日に移動します。

メニューボタン [image] を押すとメニューが出ます。

新規...：新規（システム時刻）データの入力を行います。

編集...：リストでデータを選択すると有効になります。データを変更できます。

ファイル出力：表示または選択しているデータをタブ区切りﾃｷｽﾄ形式でファイルに出力します。

複数選択：リストで任意の複数のデータを選択することができます。選択後、ファイル出力では選択データだけが出力されます。

一覧を終了：この画面を閉じます。OKボタンでも同じです。

ファイル出力

期間とファイル形式を指定して小遣いデータを出力することができます。

終了日とファイル形式を選択してOKボタンを押してください。

Okボタンを押してください。

出力されたファイルが選択された状態でこの画面が出ます。フォルダ間でファイル移動やメール添付などが可能です。（参照：ファイル操作）

ポケットエクセル形式の場合

OKで閉じます。

元の画面に戻ります。

ここでOKボタンを押すと終了期日と残高を記憶します。キャンセルボタンを押すと出力ファイルを削除します。

ファイル名は04年０９月２０日までの小遣い清算なので040920小遣い清算となっています。

グラフ用データ

現時点のグラフ表示機能は貧弱です。バージョンアップで対応していこうと考えています。現時点で詳細なグラフを作るにはデータをファイル出力して、デスクトップのｴｸｾﾙなどを使うしかありません。

グラフデータは５種類設定できます。１種類のデータに４つの元データを指定できます。その４つのデータを元に計算式をあてはめて計算した結果をグラフ表示します。

設定

グラフデータはグラフ設定をしてからデータ入力します。メニューの「設定」－「グラフ。。。」を選択します。この「グラフ。。。」はグラフに名前をつけた時点でその名前になります。

例として燃費データとします。

データ名：燃費

単位：ｋｍ （本当は km/lなのですが、文字数が足りません）

目標値：グラフに横線が入ります。

項目A：ガス　ガソリンのことです。

項目B：距離

式：B/A　　　距離（ｋｍ）÷ガソリン（リットル）　　これは任意の四則演算式を指定できます。定数も指定できます。 (A+B+50）/(C*D)など

締日：データを加算してグラフを描く場合、加算するにチェックを入れて、この締日でクリアする日を指定します。

次へボタンで次の画面へ移ります。

Y軸のスケール（最大、最小）を指定します。

自動は記憶しているデータの最小値、最大値を元にスケールを決めます。

上限値、下限値を指定した場合はグラフの表示の上限と下限は指定した値になります。

Okボタンで設定完了です。

設定後は以下のようになります。

グラフ５は株価などで使うローソク足グラフです。A：最高値、B：最低値、C：高値、D:低値です。

入力

入力する方法はいくつかあります。

●画面右下のアイコン [image] をドラッグして時刻バーの横にもっていく

●画面右下のアイコン [image] をタップする

●画面右下のアイコン [image] をタップ＆ホールドして、「新規」メニューを選択する

●画面右下のアイコン [image] をタップ＆ホールドして、「一覧」「検索」を選択後、その画面のメニューで「新規」を選択する

●メニューの「新規」で、「グラフ」を選択する。

●メニューバー内の新規アイコンをクリックして「グラフ」を選択する

すべての新規はシステム時刻で作られます。

新規画面は以下のようになります。（例として燃費画面です）

ガスAの入力項目にガソリン量を入力します。距離Bの入力項目に走行距離を入力します。入力方法は、SIP（ソフトキーボード）を使っても良いですし、「１０」ボタンを押して電卓を出しても入力できます。 （参照：電卓ボタンの動き）

値を入力すると、結果欄に計算結果が表示されます。

燃費以外のデータを入力する場合は、コンボボックス（上記では1赤 燃費）で選択してください。

変更する場合は時刻バーの横のアイコン（ [image] に色がついています）をタップしてください。

表示

データをグラフ表示します（現時点の表示機能はとても貧弱です。）

表示メニュー、燃費をチェックオンします。

燃費グラフが表示されます。横軸は約2ヶ月分です。縦線が2本ありますが、これは8月1日と9月1日の位置です。赤い横線が目標値です。スケールは画面が小さいので表示していません。日付を移動してもその時点ではグラフを書き直していません。その日付でのグラフを再表示させるには、グラフをタップしてください。 なお、折れ線グラフのX軸位置はを０にするには、設定で上限値、下限値を設定して、それらを有効にしてください。

グラフを非表示にするには、表示メニューでチェックオフしてください。なお、プログラム再起動すると表示無しとなります。 バイオリズムが有効な場合はバイオリズムを表示します。

現時点ではこのサイズでしか表示できません。汎用的なご要望が多ければバージョンアップ するか、別のグラフ処理するだけのプログラムを開発します。

一覧、検索

画面右下のアイコン [image] をタップ＆ホールドしてメニューを出します。

一覧または検索を選択してください。右側の画面となります。

右上の [image] ボタンを押すとメニューが出ます。

新規...：新規（システム時刻）データの入力を行います。

編集...：リストでデータを選択すると有効になります。データを変更できます。

ファイル出力：表示または選択しているデータをタブ区切りﾃｷｽﾄ形式でファイルに出力します。

複数選択：リストで任意の複数のデータを選択することができます。選択後、ファイル出力では選択データだけが出力されます。

一覧を終了：この画面を閉じます。OKボタンでも同じです。

燃費～グラフｘ：この画面ではグラフデータを全て表示します。燃費だけを表示したい場合は燃費のチェックだけを残して他をチェックオフしてください。

Goボタン：データを１件だけ選択した状態でこのボタンを押すと、この画面を閉じて、そのデータの日付に移動します。

日付～日付：この期間のデータを表示しています。任意の期間に変更できます。最初は2ヶ月間です。

検索画面は以下のようになります。検索データを指定し、検索ボタンを押すと、検索データが含まれる表示データだけを残して表示します。これを繰り返すことでデータを絞り込むことができます。その他の機能は一覧と同じです。

ファイル出力

ファイルメニューから選択します。前述の一覧と検索は表示データをﾃｷｽﾄ形式で出力しますが、ここでは形式選択できます。

まず、グラフのデータ種別を選択します。

次に期間と出力形式を指定します。

形式は、PocketExcel形式、TXTタブ区切り形式、CSVカンマ区切り形式から選択します。

OKを押すと出力ファイルを作成します。

OKを押します。

出力されたファイルが選択されています。必要であれば、フォルダを移動させたり、内容を確認したい場合は起動ボタンで確認などができます。 （参照：ファイル操作）

起動ボタンを押した場合の例を以下に示します。（この場合ポケットｴｸｾﾙが起動しています。列幅を調整しました）

列の出力順序は左から、データA、データB、データC、データD、日付、時刻、計算結果の順です。

ヘッダー部には計算式などが出力されています。

CSV形式もTXT形式も出力順序は同じです。（デスクトップのｴｸｾﾙで読み込めば同じ順序になります）

OKを押すと画面が戻ります。

ここで、キャンセルを押すと、画面を閉じた後、出力ファイルが残っていれば削除するかどうかの確認が出ます。OKを押すとそのまま終了します。

日付移動

表示日付を移動させる

日付の移動は、同一月内なら、カレンダーの日付をタップしてください。

先月に移動するには、カレンダーの曜日が表示されている場所をタップしてください。カレンダーが先月になります。

翌月に移動するには、カレンダーの下部の日付が表示されていない場所をタップしてください。翌月になります。

指定の日付に移動するにはカレンダーをタップ＆ホールドしてメニューを出してください。

今日へ：システム日付に移動します。

翌日へ：現在日付の翌日に移動します。

前日へ：現在日付の前日に移動します。

最新へ：最新データの入力されている日付（最新日付）へ移動します。

指定日：ダイアログが表示されます。

任意の日付を選択してOKボタンを押してください。

時刻移動

表示時刻を移動させる

表示時刻は簡単に移動できます。

赤い印のところをタップするとその方向にシフトします。上限と下限にぶつかった時点でその方向のシフトは出来なくなります。

任意の時刻に移動させることは出来ません。

参照：表示設定

ファイル操作

一般的なファイル操作ができます。

OK：この画面を閉じます。

起動：ファイルリストで選択しているファイルを開きます（プログラムを起動します）

移動：ファイルリストで選択しているファイルを移動します。移動中はボタンが「移動中」という表示に変わります。移動先は画面上部のﾌｫﾙﾀﾞかメール添付ファイルかのいずれかです。移動複写手順を参照

名変更：ファイル名を変更できます。

削除：ファイルを削除できます。

画面右上のﾌｨﾙﾀｰは追加できます。「追加」ボタンを押してください。形式は　XXXX(*.xxx)のように*.xxxをカッコで囲んで指定してください。

画面上の「ディレクトリ」をタップすると「ﾌﾟﾛｼﾞｪｸﾄ」になります。

この画面はMy Documents内のファイルのみを対象としています。また、ディレクトリはMy Documentsの下にあるディレクトリだけで、その下は対象ではありません。ちょうど、PocketPCで表示される普通のファイル選択ダイアログのような形です。メモリとメモリカードの選択などが出来ます。移動はこの画面では出来ません。

移動（複写）操作手順

フォルダ間で移動、複写する場合は、移動（複写）先をフォルダーツリーで見えるように開いておいてください。

ファイルリストでファイルを選択した後、移動ボタンを押すと

ファイルをﾌｫﾙﾀﾞ間で移動する場合は「はい」、送信トレイに入れる場合は「いいえ」を選択します。

「はい」を答えると、

ﾌｫﾙﾀﾞを選択すると、

移動、コピー（複写）の選択となりますので、選択してください。

バックアップとリストア

バックアップをこまめにとる

バックアップを取得しておくことで、データ破壊の危険をある程度は回避することができます。バックアップ処理は単純にデータファイルをCOPYするだけです。

このプログラムは自身のデータファイルを最新５件までバックアップします。5件になると、最も古いファイルを削除し、新しいバックアップファイルを作ります。

なお、バックアップファイルを開くことも可能ですが、編集は出来ません。バックアップファイルを開くには、まず、バージョン情報ダイアログでPACファイルを関連づけしたあと、プログラムを終了させ、ファイルエクスプローラーでpAchiBackup?.pacファイルをタップして起動します。以下のように表示されます。

リストアする

バックアップしたPACファイルを指定します。リストアする項目を選択します。現在のファイルにデータを重ねてリストアされます。同じ時刻のデータは上書きでリストアされますので、現在のデータで旧データと異なる時刻のものが残り、同じものは旧データに戻ります。但し、内容が同じで時刻の異なるもの、例えば時刻を移動したデータなどは2重となります。一般的にはリストアはしないでください。バックアップデータに戻したいだけなら、My Documentsの pAchi.PACを削除し、戻したいいpAchiBackup?.PACを pAchi.PACに名前を変えてください。

通常、リストアは期間の判明しているデータだけ、または、データ以外の定義情報だけを旧データから取得したい場合に使います。

旧版Version1.0のデータもリストアできます。

データファイルと状態表示

データファイルは開かれている

プログラムが実行中の間は常にデータファイルは開かれています。データファイルは pAchi.PACという名前で\My Documentsに作成されています。約６２５KBです。この位置を動かすことは出来ません。また、My DocumentsをActiveSyncで同期するように設定していると、プログラム実行中はこのデータファイルの同期が行われません。常に開いているのは、常にデータをファイルに書き戻しているからです。プログラムは入力されたデータは即座にファイル上に書き戻すようにしていますので、不意なソフトリセットやプログラムの強制終了にあっても最新データを保持できます。

ActiveSyncで同期する際はこのプログラムを一旦終了させてください。

データファイルの内部状態と無効領域の圧縮

データファイルの内部状態を見るには以下のようにメニューから指定します。

容量と現在の使用量、圧縮可能な件数などが表示されます。

プログラムでデータを削除しても実際はデータ領域に削除マークを付けているだけで領域は使用したままです。これらの領域は定期的（年に1回程度）に圧縮する必要があります。最大データ件数は９９５０件です。圧縮可能な件数で表示されているデータを削除＆圧縮可能です。必要であれば1年前削除、2年前削除で無効データを圧縮してください。

データが容量いっぱいに近づくと操作中に警告がでるようになります。

注意：圧縮してもデータファイルのサイズは小さくなりません。データファイルのサイズは固定です。

新規メニュー

メニュー左の「新規」は共有メニューにすることができます。Windowsのｽﾀｰﾄボタン－設定－個人用にて「メニュー」を選択します。「新規メニュー」タブを選択し、「［新規］メニューをオンにする」にチェックを入れます。これにより、「新規」メニューの横にボタンが現れます。

新規を押すと、右のように項目入力となり、ボタンを押すと左のように共有新規となります。前述の共有を設定しなければ、常に左側の画面となります。

ここで作成される新規項目（このプログラム内のデータ）はシステム時刻で作成されます。現在表示中の日付がシステム日付でない場合は新規データと表示日が異なりますのでご注意ください。

電卓ボタンの動き

電卓ボタンを押すとPocketPCの電卓が現れます。

すぐに、元データ値が表示されます。（実数の場合は小数6桁程度の表示になります）

新しいデータを入れる場合はCキーを押してクリアしてから新しい計算を始めてください。

PocketPCの×ボタンで電卓を閉じると元の画面に戻ります。タスクマネージャーで元のプログラムに切り替えても、電卓を終了させても同様に値は取り込まれます。

バージョンアップ情報

バイオリズム Ver1.0.2以降

バイオリズムを表示できます。

「設定」－「基本設定」－「バイオリズム」にて

誕生日と時刻を指定し、[バイオリズムを表示する」にチェックを入れます。

バイオリズムは3種の周期で表される生体の状態とのことで、青：肉体、赤：感情、緑：知性を表します。これらの値が０点と交差するときに不安定となるという理論です。真ん中の薄紫の四角とグラフが交差する場合は要注意日ということです。

前後15日程度を表示しています。

以上

20041012 Ver2.1.0
プロジェクト別時間管理を追加
プロジェクト予定を追加

20040921 Ver1.1.0
不具合修正、機能変更追加

20040910 Ver1.0.2
ファイル操作のﾌｫﾙﾀﾞｰツリーにアイコンを表示。バイオリズムを追加、グラフのY軸スケール指定を追加など。

20040904 Ver1.00

Copyright (C) 2004 P.I.E. Ltd.

担当：大久保


シェアウェア代金の支払い方法

シェアウェアについて

      シェアウェア代金は500円、または1890円です。

    以下の口座にお振込みをお願いします。なお、お振込みさ
れた場合は必ず電子メールでご連絡ください。代金は理由
の如何に係わらずお返しできません。

銀行振込の場合は以下の口座へお願いします。

          みずほ銀行　　　小田急相模原支店

          普通預金　　　９０９５３０

          口座名義人　　株式会社　ピー･アイ･イー

          金額　500円または1890円　　振込み手数料は別途お支払いください。

                            振込み手数料は郵便振替の方が安い(70円）です。

        郵便振替口座を用意しましたので、以下の口座でも結構です。

          口座番号　　００２４０－５－２２１０

          口座名称　　（株）ピー・アイ・イー

          金額　500円または1890円　振込み手数料（７０円）は別途お支払いください。

          入金確認に数日かかります。

           記入例

      連絡用メールのタイトルは「ｘｘｘｘｘライセンスキーr代金」としてください。

xxxxxxの位置にはプログラム名を入れてください。

      内容は、振込人のお名前（必須です）を入れてください。

ライセンスキー入力時は半角で入力してくださいね！

その他は何を書かれても構いません。ライセンスキーは
電子メールで返信しますので返信可能な設定でお送りください。

    必ず電子メールで連絡してください。入金だけされても返信できません。

      住所：相模原市相模大野4-5-2-1201

      株式会社ピー･アイ･イー

担当：大久保 茂人

      連絡用メールを出す